Trial Signups Failures
Incident Report for Mattermost
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 09:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 29, 2024 - 09:09 UTC
Investigating
We are currently investigating this issue.
Posted Jul 29, 2024 - 08:39 UTC
This incident affected: Sign-Up.